
Rename File Window
WavSorter displays the Rename File window when you select a file in the File listbox, and 
select Rename from the File menu.
The current name of the file is displayed here; edit it to change the name of the file 
(remember that DOS filenames consist of a maximum of eight characters, a period (.), and a 
three-letter extension).
Click Rename to rename the file, or click Cancel to skip it.



Rename Directory Window
WavSorter displays the Rename Directory window when you select a directory in the 
Directory listbox, and select Rename from the File menu.
The current name of the directory is displayed here; edit it to change the name of the 
directory (remember that DOS directory names consist of a maximum of eight characters, a 
period (.), and a three-letter extension, just like filenames).
Click Rename to rename the directory, or click Cancel to skip it.



Create Directory Window
WavSorter displays the Create Directory window when you select a directory in the Directory
listbox, and select Create Directory from the File menu. When you create a new directory, 
you'll create it as a subdirectory of the selected directory.
The name of the directory you selected is shown in the top box. Enter the name of the new 
directory in the lower box.
Click OK to create the new directory, or click Cancel to skip it.



Delete Directory Window
WavSorter displays the Delete Directory window when you select a directory in the Directory
listbox, and select Delete Directory from the File menu.
This window displays the name of the directory you selected. Double-check the name, and 
either click OK to proceed or click Cancel to skip it.



Directory Not Empty Window
WavSorter displays the Directory Not Empty window when you try to delete a directory that 
has files in it. This is a safety feature, since deleting a directory also means deleting the files 
in it. You have two choices:
· Click Continue to tell WavSorter to proceed, and delete all the files in the directory.
· Click Cancel to abort the entire operation.

You have an additional option with Continue: if Confirm Deletes is checked, you can 
proceed, and then decide for each file individually whether to delete it. Note, however, that if 
you leave any files in the directory, you can't delete the directory when you're done.



Folder Not Empty Window
WavSorter displays the Folder Not Empty window when you try to delete a folder (which 
represents a directory) that has files in it. This is a safety feature, since deleting a directory 
also means deleting the files in it. You have two choices:
· Click Continue to tell WavSorter to proceed, and delete all the files in the directory 

represented by the folder.
· Click Cancel to abort the entire operation.

You have an additional option with Continue: if Confirm Deletes is checked, you can 
proceed, and then decide for each file individually whether to delete it. Note, however, that if 
you leave any files in the directory, you can't delete the directory when you're done.



Create File Association Window
WavSorter Pro Feature!

WavSorter displays the Create File Association window when you select Windows File 
Association from the Edit menu. It lets you create or change a Windows file association from 
within WavSorter Pro.



Assign System Sounds Window
WavSorter Pro Feature!

WavSorter displays the Assign System Sounds window when you select Windows System 
Sounds from the Edit menu. It lets you change, from within WavSorter Pro, the sounds 
Windows associates with certain system events.



Warning Window
WavSorter displays this window when you try to delete a folder (which represents a 
directory) that has files in it. This is a safety feature, since deleting a directory also means 
deleting the files in it. You have two choices:
· Click Continue to tell WavSorter to proceed, and delete all the files in the directory.
· Click Cancel to abort the entire operation.

You have an additional option with Continue: if Confirm Deletes is checked, you can 
proceed, and then decide for each file individually whether to delete it. Note, however, that if 
you leave any files in the directory, you can't delete the directory when you're done.



Edit Folder Window
This window lets you create or change a folder's label, and assign or reassign the directory it 
represents; or clear a folder (make it turn gray). 
Setting Up an Empty (Gray) Folder
Changing a Folder's Directory Assignment
Changing Only a Folder's Label
Clearing a Folder (Making it Turn Gray)

See Also: Working with Folders



Setting Up an Empty (Gray) Folder
· Select a directory in the Directory listbox. Hold down the Shift key and drag the directory

name to a gray folder, and drop it.
Or:

· Select a directory in the Directory listbox. Click on a gray folder; it will be highlighted. 
Then select Folder from the Edit menu.

WavSorter displays the Edit Folder Window. The Current box will be empty, because this 
folder hasn't been set up yet. The New box shows the directory you selected in the Directory 
listbox.
If you want to select a different directory to assign to the folder, click Browse. WavSorter 
displays a dialog box that lets you select a new drive and directory. When you've done that, 
click OK in that dialog box to return to the Edit Folder Window.
Type a label for the folder in the Label box. Labels can be no more than eight characters 
long.
Press Enter, or click OK. The folder will turn blue, indicating that it's been set up.



Changing a Folder's Directory Assignment
If you want to change the directory assigned to a folder:
· Select a directory in the Directory listbox by single-clicking on it. Hold down the Shift 

key and drag the directory name to the blue folder you want to change, and drop it.
Or:

· Click on the blue folder; it will be highlighted. Then select Folder from the Edit menu.
WavSorter displays the Edit Folder Window. The Current box shows the directory currently 
assigned to the folder. The same directory also appears in the New box.
To select a different directory to assign to the folder, click Browse. WavSorter displays a 
dialog box that lets you select a new drive and directory. When you've done that, click OK in 
that dialog box to return to the Edit Folder Window.
If you also want to change the folder's label, type the new label for the folder in the Label 
box. Labels can be no more than eight characters long.
Press ENTER, or click OK.



Changing Only a Folder's Label
Select the folder by clicking on it, then select Folder from the Edit menu. WavSorter displays 
the Edit Folder Window. Type the new label in the Label box, then press ENTER, or click 
OK.



Clearing a Folder (Making it Turn Gray)
You can also use the Edit Folder Window to clear a folder; this means that it will no longer 
have a directory assigned to it, nor will it have a caption.
Click on a blue folder; it will be highlighted. Then select Folder from the Edit menu.
WavSorter displays the Edit Folder Window. Click Clear Folder; WavSorter sets the 
directory and label to blank. Then press ENTER, or click OK to officially clear the folder; or,
if you change your mind, just click Cancel.



Duplicate Files Window
If, while copying or moving a file, you encounter a file at the destination with the same name
as the one you are copying or moving, the operation is halted and WavSorter displays the 
Duplicate File Names window. 
The file you want to copy or move (called the "source" file) appears on the left, the file with 
the same name at the destination (called the "target" file) appears on the right. 
WavSorter displays the statistics and directory of both files, to give you one basis for 
comparing the two. Another way to compare the files is to click either file's Listen button, to 
play the files.
You have several options in this window for how to proceed:
· Click the Replace button to delete the target file and copy or move the source file to the 

destination.
· Click the Rename button to open the Rename File window, enter a new name for the 

source file, and press ENTER or click OK. The source file will be renamed and copied or 
moved to the destination.

· Clicking the Delete button will delete the source file from the source directory, and then 
continue.

· Click Skip to skip the operation for this file, and continue with any files remaining in the 
operation.

· Click Cancel to abort the entire operation; any files remaining to be copied or moved 
won't be, but (of course) files copied or moved previously stay that way (this isn't an 
Undo button).

Hint: Right-click on the file name for the complete path of the file.



File Statistics
Provides information about file size, date and time last saved or changed, and attributes 
(hidden, system, readonly, normal, and archive).

See: Displaying File Statistics



Directory Statistics
Provides information about the size of the currently-selected directory, and the number of 
files contained in that directory.

See: Displaying Directory Statistics



Create Directory
Lets you create a new directory under the currently-selected directory.

See: Creating a Directory



Delete Directory
Deletes the selected directory.

See: Deleting a Directory



Rename File
Opens a window for renaming the selected file.

See: Renaming a File



Rename Directory
Opens a window for renaming the selected directory.

See: Renaming a Directory



Exit
Clicking on this exits WavSorter. If you've changed your configuration and haven't saved the 
changes to a configuration file, WavSorter will ask you if you want to save your 
configuration.



Edit Folder
This item displays a window in which you assign a directory and a label to folders, or clear a 
folders label and directory assignment.

See: Working with Folders
Edit Folder Window



Edit Custom Toilet Sound
This item displays a dialog box in which you select a custom sound WavSorter will use when
deleting. WavSorter will use your file when you select Custom Toilet Sound under the Sound 
Effects item on the Options menu.

See: Toilet (Deletion) Sound Effect Options



Edit Custom Launch Sound
This item displays a dialog box in which you select a custom sound WavSorter will use when
launching a file. WavSorter will use your file when you select Custom Launch Sound under 
the Sound Effects item on the Options menu.
Launch sounds are available only with WavSorter Pro.



Edit Windows System Sounds
WavSorter Pro Feature!

Yes indeed, with WavSorter Pro you can assign system sounds from within WavSorter. Nice 
touch.

See: Assigning System Sounds



Edit Custom Drag/Drop Icon
Displays a dialog box for choosing and assigning your own icon for drag and drop 
operations.

See: Assigning Drag Icons



Edit Windows File Association
WavSorter Pro Feature!

Opens a window for associating a file extension with an .EXE, .COM, .BAT, or .PIF file. 
See: Associating a File

Launching Files



Toilet Sound Effect
Toilet sound effects are available only with WavSorter Pro.



Launch Sound Effect

These three items control the sound effect associated with launching a file. Only one of the three 
items can be selected at a time; the one that's selected is checked. Check an item by selecting it 
from the menu.
See: Launch Sound Effect Options



Message Box Sounds

WavSorter can use the Windows system event sounds as a sound effect to accompany the various
message dialog boxes it displays. Select Message Box Sound Off or Message Box Sound
On to control whether WavSorter uses these sounds.
See: System Event Sounds



Drag Icon Options

These four items select the icon used during drag operations. Only one of the four items can be 
selected at a time; the one that's selected is checked. Check an item by selecting it from the 
menu.
Note:    The Custom Icon item is available only with WavSorter Pro.
See: Configuring Drag Icons



Confirm Deletes
If this item is checked, you will be prompted for confirmation before a file is deleted. Toggle 
this item on and off by clicking on it. By default, Confirm Deletes is always on when you 
start WavSorter.

See: Deleting a File
Deleting a Directory
Deleting the Contents of a Folder



Show Size in KB
If this item is selected, file size and directory size will be displayed in kilobytes. Otherwise, 
size is displayed in bytes. Toggle this item on and off by clicking on it.

See: File Statistics
Directory Statistics



Show Sound Queue
This option controls whether WavSorter displays a window showing the sound queue while 
its playing files. The Sound Queue Window shows the files in the queue, and the file 
currently playing.

See: Playing the Contents of a Folder
Playing the Files in a Directory
Configuring WavSorter



Default Drag/Drop Operation
To set the default drag/drop operation, choose "Default Drag/Drop Operation" from the 
Options Menu, then click on either "Copy" or "Move". The menu items "Copy" and "Move" 
control which type of operation is performed by a drag-and-drop. You can override the 
default by holding down the Ctrl key while you drag (if the default is move, it becomes copy;
if the default is copy, it becomes move).

See: Default Drag Operation



Load Configuration
WavSorter Pro Feature!

Opens a dialog box for selecting and then loading a stored configuration.
See: Managing Configurations

Configuring WavSorter



Save Current Configuration
Saves your current configuration to disk, so that it can be used next time you start WavSorter.

WavSorter Pro Feature! WavSorter Pro can store multiple 
configurations.

See: Configuring WavSorter



Save Current Configuration As
WavSorter Pro Feature!

Displays a dialog box for saving your current configuration under a name other than the one 
you are now using.

See: Managing Configurations
Configuring WavSorter



New Configuration
WavSorter Pro Feature!

This item resets all the settings in WavSorter to their defaults, and empties all the folders 
(makes them grey, or not set up; it doesn't do anything to their assigned files or directories). 
This is useful to make WavSorter a "blank slate" for you to start a new configuration.

See: Managing Configurations
Configuring WavSorter



Contents
Clicking on this item opens the help window and provides you with a list of WavSorter help 
topics.

See: Help Contents



Search
Opens a dialog box for searching WavSorter help. Works very much like using an index.



Magic Target Help
MT Help provides quick information in a popup box about all menu items, buttons, and most 
controls in WavSorter. If you want to use the hypertext "jumps" (the green text in the popup 
box), start WavSorter Help before turning on Magic Target Help. Do this by choosing 
"Contents" from the Help Menu before choosing "Magic Target Help".
If you're trying to turn off Magic Target Help, click on the box labeled "Click here when 
down with MT help."
HINT:    Use Magic Target Help to take a guided tour of    WavSorter.

See: Using Magic Target Help



Getting Started
This item provides an overview of WavSorter, a quick start guide, and a description of 
WavSorter Pro.

See: Getting Started



Shortcuts and Techniques
Choose this item for suggestions on easy and efficient ways to utilize WavSorter's features.

See: Shortcuts and Techniques



Commonly Asked Questions
Choose this item for answers to commonly asked technical support questions. If you don't 
find the information you need, you can contact Shepherd Software for assistance.



WavSorter Pro
You're using the evaluation version of WavSorter. When you register, you'll receive the 
current version of WavSorter Pro, with even more features and enhancements. Click on this 
item for a description of WavSorter Pro and how to order.

See: WavSorter Pro



Ordering WavSorter Pro
You're using the evaluation version of WavSorter. When you register, you'll receive 
WavSorter Pro, with many more features and enhancements. Click on this item for 
information about how to register and receive WavSorter Pro.

See: Ordering WavSorter Pro



About WavSorter
Displays information about the evaluation version of    WavSorter, including version number.



FileName Panel
When you select a file, WavSorter displays its complete path in this box. Copy, move, delete, 
and play operations are performed on the file which is displayed here.





About Folder Statistics
Selecting Folder Statistics... from the File Menu or pressing F8 will provide information 
about the directory assigned to the highlighted folder, including number of files, size, and 
complete path.

Hint: Right-clicking on any folder will also provide information about that folder.



WavSorter Pro Order Form
To register and order WavSorter Pro by mail, print this order form by selecting Print Topic 
from the help File menu (not the WavSorter file menu). Fill out the order form and mail it to:
Shepherd Software
6984 McKinley St.
Sebastopol, Ca.    95472
Be sure to include a check or money order (U.S. funds) for the appropriate amount.

SHIP TO:
Name:___________________________________
Address1:________________________________
Address2:________________________________
City:_______________    State:___    Zip:_________
Phone (optional) _________________
FAX (optional) __________________

PRODUCT INFORMATION:
Quantity ___
Disk Preference (check one)
___ 3.5 inch high-density

___ 5.25 inch high-density

SUBTOTAL ($14.95 per unit) __________
SALES TAX (multiply subtotal by 7.5%) __________
SHIPPING ($3.00 per unit) __________

TOTAL COST: __________



Commonly Asked Questions
COMMONLY ASKED TECHNICAL SUPPORT QUESTIONS

"When I start WavSorter, I receive the error message "Invalid Object Use"

"When I try to play a .wav file, I receive an error message with ERROR 263 in the upper 
right hand corner of the message box"

"When I try to play a sound file (.wav or .mid), I receive an error message with ERROR 326 
or ERROR 343 in the upper right hand corner of the message box"

"I can play .wav files through my PC speaker, but cannot use WavSorter to play files"

"When I play a sound file, the end of each file is 'cut off'"

"When I try to play a directory or folder, WavSorter plays the first sound file in the sound 
queue and then stops playing. I then have to click the "Stop" button in order to reset the 
"Play" and "Play Directory" buttons so I can play another file"

"When I drag a file to a folder, there's a noticeable 'jump' when the drag icon crosses the 
midpoint of the window. Also, if I move the cursor over another file in the file list box, that 
file is highlighted and copied or moved instead of the file I started the drag operation with."

"When I start WavSorter for the first time, I receive an 'Invalid Path', 'Device Unavailable', or
'Drive Not Ready' error."

"After using WavSorter, and saving my configuration, I receive an 'Invalid Path', 'Device 
Unavailable', or 'Drive Not Ready' error."

"The file list box does not display all the files in a directory or folder."

"The Directory Statistics and Folder Statistics information doesn't match what is displayed in 
the file list box."

"When I copy, move, or delete a directory's or folder's contents, only the files displayed in the
file list box are copied, moved, or deleted."



"When    I start WavSorter, the colors of my wallpaper change and then after WavSorter's 
main window appears, the colors of my wallpaper return to normal."

"What is the proper pronounciation of 'WavSorter?'"



Commonly Asked Questions
This error means that WavSorter cannot find VBRUN300.DLL or one of the MicroSoft .VBX
files included with WavSorter (MCI.VBX and THREED.VBX). WavSorter will not run 
properly with older versions of the MicroSoft .VBX files (those with dates older than 
4/28/93), nor will it run with VBRUN100.DLL or VBRUN200.DLL. Make sure you have 
installed the .VBX files included with WavSorter in your Windows "system" directory. Also 
make sure you have VBRUN300.DLL in your Windows "system" directory.



Commonly Asked Questions
This error means you do not have the drivers [MCI] Sounds and [MCI] Sequencer installed. 
If you have a sound card present when you install Windows 3.1, these drivers are added 
automatically. If you install a sound card after you've installed Windows 3.1, you must add 
these drivers manually. To add the drivers, do the following:
In Control Panel, choose "Drivers", click on the "Add..." button, select [MCI] Sound, and 
click the "OK" button; repeat for [MCI] MIDI Sequencer.



Commonly Asked Questions
This error occurs when you attempt to play a sound file (.wav or .mid) through your PC 
Speaker. You must have a sound card (SoundBlaster, AdLib, Pro Audio Spectrum, etc.) 
installed in order to use WavSorter. If you do have a sound card installed but still receive this 
error, check to make sure you have the MCI drivers installed.To add the drivers, do the 
following:
In Control Panel, choose "Drivers", click on the "Add..." button, select [MCI] Sound, and 
click the "OK" button; repeat for [MCI] MIDI Sequencer.



Commonly Asked Questions
You must have a sound card (SoundBlaster, AdLib, Pro Audio Spectrum, etc.) installed in 
order to use WavSorter.



Commonly Asked Questions
This is due to using incorrect drivers. You must have the MCI drivers, [MCI] Sounds and 
[MCI] Sequencer, installed. If you have a sound card present when you install Windows 3.1, 
these drivers are added automatically. If you install a sound card after you've installed 
Windows 3.1, you must add these drivers manually. To add the drivers, do the following:
In Control Panel, choose "Drivers", click on the "Add..." button, select [MCI] Sound, and 
click the "OK" button; repeat for [MCI] MIDI Sequencer.



Commonly Asked Questions
This situation occurs when something prevents your sound card from notifying WavSorter 
when a file is done playing. First, make sure you're not closing the sound queue when a file 
starts playing. This clears the queue, prevents WavSorter from resetting the buttons and 
OpLight, and generates an "Invalid Device ID" error the next time you play a file.
If you're not closing the sound queue while a file is playing, then the problem is due to not 
having the MCI drivers, [MCI] Sounds and [MCI] Sequencer, installed. If you have a sound 
card present when you install Windows 3.1, these drivers are added automatically. If you 
install a sound card after you've installed Windows 3.1, you must add these drivers manually. 
To add the drivers, do the following:
In Control Panel, choose "Drivers", click on the "Add..." button, select [MCI] Sound, and 
click the "OK" button; repeat for [MCI] MIDI Sequencer.



Commonly Asked Questions
The "jump" phenomenon is due to the way WavSorter differentiates between a click and just 
holding down the mouse button to drag an object. A timer is used to delay the start of a drag 
operation while WavSorter checks to see whether the user has clicked the mouse button or is 
holding the button down. The length of the timed delay varies according to the double-click 
speed, as set by the user inControl Panel. If you'd like WavSorter to begin drag operations 
more quickly,simply adjust the double-click speed in Control Panel. Do this by 
choosing"Mouse" in the Control Panel window, then adjust the double-click speed to a faster 
setting. Another solution is to wait until the cursor changes to a drag iconbefore beginning 
your drag operation.

The reason a file is highlighted when you move the cursor over it while dragging is due to the
fact Visual Basic interprets the presence of the cursor over a filename as indicating you want 
to select that file. Since WavSorter performs a copy, move, or delete operation on the 
highlighted file, this will result in an unintended operation being performed if you've moved 
the cursor over another filename in the file list box before the cursor changes to a drag icon. 
To prevent inadvertently highlighting a file, wait until the cursor changes to a drag icon 
before dragging the file.



Commonly Asked Questions
When WavSorter starts, it checks its current .ini file ('default.ini' for the evaluation copy of 
WavSorter) for the last path selected. If the person who uploaded WavSorter included his or 
her default.ini file, you will receive this error because WavSorter cannot find the last path 
selected; it does not exist on your system.
To avoid this problem, simply delete the default.ini file from your WavSorter directory. 
WavSorter will create a new default.ini file configured for your system and preferences the 
first time you save changes to your configuration (from the Options Menu, choose 
"Configuration..." and click on "Save Configuration", or simply choose "Yes" when asked if 
you want to save changes when exiting WavSorter).



Commonly Asked Questions
The cause of this error is that WavSorter cannot find the path that was currently selected the 
last time you exited WavSorter and saved changes to your configuration. This will occur, for 
example, if the last path selected was on a floppy drive, network drive, or CD-ROM and the 
drive is now either unavailable (as in a network drive) or you have a different floppy or CD-
ROM disk in the drive. This error will also occur if you've deleted the directory that was last 
selected since the last time you exited WavSorter and saved changes to your configuration. 
When you receive this error, do one of the following:
1. Choose "Cancel" when you receive this error, in which case WavSorter will continue 
loading and will use your WavSorter directory as the default directory.
OR
2. Choose "Cancel" when you receive this error, exit WavSorter without saving changes to 
your configuration, re-connect to the network drive which has the directory you want on it, 
and start WavSorter again.
OR
3. Insert the floppy or CD-ROM disk which has the directory you want on it into the drive, 
make sure the device is ready (e.g., door closed or tray in) and choose "Retry".
If you've deleted a directory which was assigned to a folder, it's a good idea to remove that 
directory assignment. Do this by clicking on the folder that has the invalid or non-existent 
directory assigned to it, choose "Folder..." from the Edit Menu, click on the "Clear Folder 
Setup" button in the Edit Folder window, and click on "OK".



Commonly Asked Questions
There is a file type box just above the file list box in WavSorter which controls which files 
are displayed. The file type list box 'filters' files according to their extension (the letters or 
numbers which appear directly to the right of the period in a filename). The file list box 
displays only those files whose extension matches the letters or numbers in the file type box. 
For example, if you've specified '*.wav' in the file type box, then only those files with 
the .wav extension will be displayed in the file list box. If you want to display all the files in 
a folder or directory, then specify "*.*" in the file type box.
You can search WavSorter help for more information about the file type box, filtering, and 
DOS file extensions. To do this, click on the 'Search' button at the top of this window. A list 
of words and phrases similar to an index will be displayed. Scroll down the list to "filtering", 
click on "filtering" to select it, click on the "Show Topics" button, and then click on the "Go 
To" button.
Or, if you prefer, you can use Magic Target Help to display information about the file type 
box.



Commonly Asked Questions
The Directory Statistics and Folder Statistics information reflects the actual contents of the 
directory or folder whereas the file list box displays a "filtered" list of files. Search help for 
information about the file type box (you can search help by clicking on the Search button at 
the top of this Window).



Commonly Asked Questions
Since WavSorter is intended as a tool for sorting files, it is designed to allow you to 'filter' 
files to work with according to their extension. For example, you might want to work with 
only the .wav files in a directory or folder. By displaying and operating on only those files 
with the .wav extension, WavSorter provides the ability to 'sift' or 'screen' files automatically 
and perform operations on them without having to tag or select multiple files manually. If 
you want to copy, move, or delete all the files in a directory or folder, simply specify *.* in 
the file type box before beginning the operation you want to perform.
You determine which files are displaying and operated upon by specifying in the file type 
box the extension with which you want to work. There are two ways to do this:
1. If you want to choose a pre-defined extension, click on the small arrow directly to the right
of the file type box. Choose the extension you want from the list by clicking on it, and then 
press ENTER.
OR
2. If you want to specify an extension which is not on the list, click on the file type box itself 
(not the little arrow), type in the extension you want (including DOS wildcards--asterisks), 
and press ENTER. For example, if you want to work with only those files with the ".txt" 
extension, you would type in '*.txt' (without the quotes) and press ENTER.



Commonly Asked Questions
The reason your Windows wallpaper changes color when you start WavSorter is due to the 
fact that Windows needs to use the palette of colors belonging to the picture of the dog in the 
startup window and so may not be able to maintain the colors of your wallpaper. Once the 
main WavSorter window appears, the colors of your wallpaper should return to normal.
This is a common problem in Windows and the change in wallpaper colors is only temporary.
These temporary changes in wallpaper color affect only the screen display of your wallpaper;
it does not in any way affect the actual bitmap you're using as wallpaper.



Commonly Asked Questions
The proper pronounciation of WavSorter is "WaveSorter" (long "a" sound).



Shepherd Software
This menu item provides information about Shepherd Software, including U.S. Postal mail 
and email addresses, and other products available.



Commonly Asked Questions
This menu item includes answers to commonly asked questions. If you experience difficulties
with WavSorter, please check to see if the answer you need is here. Chances are it will be. 
However, if you do not find the answer you need, contact Shepherd Software for assistance.



Configuring WavSorter
You control how WavSorter 
works with items on the 
Options menu (one exception is
your selection for the type of 
file displayed, which is 
controlled by the File Type 
controls).

WavSorter remembers your configuration, so that your selections will be used the next time 
you run WavSorter. With WavSorter Pro, you can also customize sound effects associated 
with launching or deleting a file, assign your own drag icon, and keep multiple 
configurations.

Sound Effects are the sounds associated with WavSorter's message boxes.
Icons are the mouse pointers used during drag and drop operations.
Confirm Deletes controls whether WavSorter asks you if you're sure when you tell it to delete 
something.
Show Size in KB determines the format in which WavSorter displays the size of files. If it's 
checked, WavSorter uses kilobytes (KB, or multiples of 1024 bytes); if it's not checked, 
WavSorter displays file sizes in bytes.
Show Sound Queue controls whether WavSorter pops up a window displaying the sound 
queue when you're playing sound files.
Default Drag/Drop Operation determines whether moving or copying is the default action 
performed by dragging.
Configuration has several commands that let you save your current configuration, and (if you 
have WavSorter Pro) manage multiple configurations.
Also, the File Type controls provide a file extension filter, which determines what kinds of files 
WavSorter lists in the File listbox.



Configuring Sound Effects
In the evaluation version of WavSorter, this item selects whether message box sounds are on 
or off. WavSorter Pro also includes items for selecting the sound effect associated with 
deleting or launching a file.
· Message Box Sounds, the sound effect that accompanies a dialog box containing a 

message from WavSorter.



Message Box Sound Effect Options

WavSorter can use the Windows system event sounds as a sound effect to accompany the various
message dialog boxes it displays. Select Message Box Sound Off or Message Box Sound
On to control whether WavSorter uses these sounds. With WavSorter Pro, you can assign the 
sounds associated with system events (including message boxes) by selecting Windows System 
Sounds... from the Edit Menu.



Configuring Drag Icons
These three items select the icon used during drag and drop operations. Only one of the three 
items can be selected at a time; the one that's selected is checked. Check an item by selecting 
it from the menu. In addition to these three items, WavSorter Pro also includes an item for 
selecting a custom icon.

Doggie Icon selects Socrates the dog, who will faithfully carry your files and objects to 
their destinations.
Spaceship Icon selects a spaceship.
Default Icon selects a more conservative icon.



Default Drag Operation
The default drag operation is the one which does not require holding down the Ctrl key when 
you start the drag. You can specify whether you want move as the default or copy, using the 
Default Drag/Drop Operation item on the Options menu.
This item has a third-level menu, listing the choices Move or Copy. The current default is 
indicated by a check mark; only one can be checked at a time. The one you select becomes 
the current (checked) default.

 Select Copy to make it the default.

 Select Move to make it the default



Confirm Deletes
If the Confirm Deletes item on the Options Menu is checked, you will be prompted for 
confirmation before a file is deleted. Toggle this item on and off by clicking on it. By default,
Confirm Deletes is always on when you start WavSorter.



Managing Configurations

WavSorter stores your configuration in a file (default.ini) in the WavSorter program directory. If 
you've made changes and then try to exit WavSorter, you'll first be asked whether you want to 
save your current configuration. WavSorter displays the name of your current configuration file 
in the caption.

Only Save Current is available in the evaluation version of WavSorter; it saves your 
current configuration in the current configuration file. You can maintain only one 
configuration in the evaluation version.

WavSorter Pro Feature!
In addition, WavSorter Pro can store and load multiple configurations.

See: Using Multiple Configurations for more information.



Using Multiple Configurations
WavSorter Pro Feature!

A central concept of both the evaluation version of WavSorter and WavSorter Pro is that you 
should be allowed to customize the interface to suit your own personality and style of 
working. Furthermore, you should be allowed to customize WavSorter and WavSorter Pro for
a variety of tasks and uses.
To suit your own personality and style, WavSorter and WavSorter Pro give you choices about
how it operates, and remembers your preferences in a configuration file. WavSorter Pro 
includes all the customizable features of WavSorter, as well as many additional features and 
enhancements. You can:
· Position WavSorter windows on the screen, and have WavSorter put them in the same 

place next time you use them;
· Choose the drag icon you want to use, either from choices provided by WavSorter Pro, or 

a graphic file you specify;
· Specify whether or not to use sound effects; and choose from the sound effects WavSorter

Pro provides, or specify your own;
· Specify whether WavSorter show sizes in bytes or kilobytes (KB) when displaying file 

statistics;
· Specify whether WavSorter asks you to confirm deletes;
· Customize folders, by assigning directories to them and attaching labels;
· Choose between move or copy as the default drag operation.

As a result, with WavSorter Pro you can create multiple configurations of WavSorter Pro, 
each customized for a specific task. For example, you might have one configuration for 
sorting wav files, another for MIDI files, and maybe one to serve as a jukebox. You can even 
create configurations for non-sound files. Sort documents, text files, database files, 
spreadsheets, or any other type of files you want. There's virtually no limit to the number and 
kinds of configurations you can create with WavSorter Pro.
In addition, WavSorter Pro accepts the name, as a command line argument, of the 
configuration you want to use when you start the program. This means you can use icons to 
represent different configurations of WavSorter Pro.

See: Multi-stage sorting



File Extension Filter
A "file extension filter" is a DOS filename pattern, such as *.WAV, that filters out all 
filenames that don't match the pattern. In the example, the asterisk (*) means "any characters 
in the first eight positions of the filename," while the .WAV part means that the last three 
letters (the extension) must be WAV.
In WavSorter, setting the file extension filter controls the files displayed in the File listbox. 
You set the filter with the File Type controls.
There are two ways to set the file extension filter:
· Click on the arrow next to the File Type box, select the extension you want from list, and 

press Enter.
Or:

· In the file type box, type the extension you want and then press Enter.



Working with Directories
Creating a Directory
Renaming a Directory
Deleting a Directory
Copying the Contents of a Directory
Moving the Contents of a Directory
Playing the Files in a Directory
Displaying Directory Statistics



Creating a Directory
In the Directory listbox, click on either the drive letter (e.g., "c:\") or the directory under 
which you want the new one. Select Create Directory... on the File Menu and the Create 
Directory window will appear. Enter the name you want for the new directory and then press 
ENTER or click OK.



Renaming a Directory
Select the directory you want to rename by clicking on it in the Directory listbox. Chose 
"Rename Directory..." on the File Menu and the Rename Directory window will appear. 
Enter the new name for the directory and then press ENTER or click on the OK button.



Deleting a Directory
You have a choice of two ways to delete a directory:
1. Select the directory you want to delete by clicking on it in the Directory listbox and then 

click the Delete   button   to delete the directory.
Or
2. Drag the directory to the Delete button and drop it on the button.
If the directory contains files, you will be asked if you want to proceed. If you want to 
proceed, you will be given a choice of either confirming the deletion of each file or deleting 
all the files in the directory without confirmation. Regardless of which way you choose, you 
will still be asked for confirmation again before deleting the directory after all the files have 
been deleted.

Hint: Since you can confirm the deletion of each file, this is handy way of "weeding" out 
unwanted files. Simply click Yes to delete a file you don't want; click No to keep a file 
you do want.



Copying the Contents of a Directory
You can drag a directory from the Directory listbox into a folder, to copy the files in the 
directory into the directory represented by the folder. Note that you can't drag files into a 
folder whose directory is the same as the source of the files (naturally).
The default drag operation setting on the Options menu affects how you drag directories. 
When you want to copy, it works like this:
· If the default operation is copy, then simply drag the directory.
· If the default operation is move, then hold down the Ctrl key while you drag. (The Ctrl 

key reverses the drag operation, so that it does the opposite of the default setting.)
See: Default Drag and Drop Operation



Moving the Contents of a Directory
You can drag a directory from the Directory listbox into a folder, to move the files in the 
directory into the directory represented by the folder. Note that you can't drag files into a 
folder whose directory is the same as the source of the files (naturally).
The default drag operation setting on the Options menu affects how you drag directories. 
When you want to move, it works like this:
· If the default operation is move, then simply drag the directory.
· If the default operation is copy, then hold down the Ctrl key while you drag. (The Ctrl 

key reverses the drag operation, so that it does the opposite of the default setting.)
See: Default Drag and Drop Operation



Playing the Files in a Directory
You have a choice of two ways to play the sound files in a directory:
1. In the Directory listbox, select the directory you want to play by clicking on it and then 

click the Play Directory   button  .
Or
2. Drag the directory to the Play Directory button and drop it on the button.

WavSorter Pro Feature! Note: Only WavSorter 
Pro can play MIDI files.

WavSorter will play, in alphabetical order, all the sound files in the directory. You can stop 
play at any time by clicking the Stop   button  . Unlike individual files, you must wait until one 
directory is finished playing before starting play of another one. Note that files will play in 
the background, which means you can continue working on other things--even minimize 
WavSorter--while a directory is playing. However, it's best to avoid copying, moving, or 
deleting a file waiting to be played since WavSorter then won't be able to find the file.
Its OK to try to play a non-sound file (one thats not a Wav or MIDI file). WavSorter checks to
make sure that a file is playable; if its not, WavSorter just skips it. However, if you have a lot 
of files in the directory you play, you may seriously tie up your computer. To prevent this, 
WavSorter stops trying after the fifth bad file.



Displaying Directory Statistics
First, select a directory by single-clicking on it in the Directory listbox. Then either click on 
the "Directory Statistics..." item on the File Menu, press F3, or right-click on the directory. A 
message box will pop up with information about directory size and the number of files 
contained in that directory.



Working with Files
Playing a File
Launching a File
Copying a File to a Folder
Moving a File
Deleting a File
Renaming a File
Assigning System Sounds
Associating a File
Duplicate Files Window
Editing a Sound File
File Statistics



Playing a File
There are three ways to play a file:
1. Select a file by clicking on it in the File listbox, then click the Play File   button  .
2. Drag a file to the Play File   button   and drop it on the button.
3. Double-click on a file in the File listbox.

WavSorter Pro Feature! Note: Only WavSorter Pro 
can play MIDI files.

There is no need to wait for a file to finish playing; you can continue choosing files in any of 
the three manners described above while a file is playing. The files will be played in the 
order they were chosen. It's best to avoid copying, moving, or deleting a file waiting to be 
played since WavSorter then won't be able to find the file. Note that if you click the Stop     
button, the queue will be cleared.
Its OK to try to play a non-sound file (one thats not a Wav or MIDI file). WavSorter checks to
make sure that a file is playable; if its not, WavSorter just skips it.



Launching a File
With WavSorter Pro, you can create and edit file associations from within WavSorter Pro. 
Once you've associated a file extension with an application, you can launch that file by either
clicking on the file in the File listbox to select it and then clicking the Launch   button  , or you 
can drag the file to the Launch button and drop the file on the button.
The evaluation version of WavSorter will only launch Sound Recorder.

Hint 1:You can launch more than one file at a time. Each application or instance of the same 
application will have the selected file for that application or instance already loaded.

Hint 2:Applications which have been started by launching work independently of WavSorter. 
They will remain open until you close them, even after you've exited from WavSorter.



Copying a File to a Folder
Copy files to folders by dragging filenames from the File listbox and dropping them on a 
folder.
The default drag operation setting on the Options menu affects how you drag files. When you
want to copy, it works like this:
· If the default operation is copy, then simply drag the file.
· If the default operation is move, then hold down the CTRL key while you drag. (The Ctrl 

key reverses the drag operation, so that it does the opposite of the default setting.)
See: Default Drag and Drop Operation



Moving a File
You move files to folders by dragging filenames from the File listbox and dropping them on a
folder.
The default drag operation setting on the Options menu affects how you drag files. When you
want to move, it works like this:
· If the default operation is move, then simply drag    the file.
· If the default operation is copy, then hold down the CTRL key while you drag. (The Ctrl 

key reverses the drag operation, so that it does the opposite of the default setting.)
See: Default Drag and Drop Operation



Deleting a File
You can delete a file using one of two methods:
· Select the file you want to delete by clicking on it in the File listbox. Click the Delete     

button to delete the file.
· Drag the file you want to delete to the Delete   button   button and drop it on the button.

With WavSorter Pro, you can assign a custom sound effect to delete operations.



Renaming a File
To rename a file:
1. Select the file you want to rename by clicking on it in the File listbox.
2. Press F4, or from the File Menu, select "Rename File..."
3. In the Rename File window, enter the new name for the file.
4. Press Enter, or click Rename to rename the file to the new name.



Assigning System Sounds
WavSorter Pro Feature!

You can tell Windows to play a sound file when certain system events take place. You could 
do this through the Windows Control panel; but it's easier and a lot more convenient to do 
this from right inside WavSorter Pro.



Associating a File
The evaluation version of WavSorter only launches Sound Recorder.
WavSorter Pro takes advantage of file associations with the Launch   button  ; it gives 
Windows the name of the file you've selected, and Windows launches the application with 
the file already loaded and ready to use.

WavSorter Pro Feature!
Further, you can edit existing file associations, or create new ones, from within WavSorter 
Pro--you don't have to go to File Manager. You'd do this with the Windows File Association 
item on the Edit menu.



Editing a Sound File
With WavSorter Pro, once you have associated your sound files with a sound editor, you can 
launch the editor to edit a selected sound file. There are two ways to do this:
· Click on the filename in the File listbox and then click the Launch   button  .
· Drag the filename from the File listbox to the Launch   button  , and drop it on the button. 

If you're not familiar with the concept of associating file extensions, see pages 130-132 of 
your Windows 3.1 User's Guide. 

Hint: You can very easily associate file extensions from within WavSorter Pro; there's no need 
to use File Manager to do it.

See: Associating a file
Launching a file



Displaying File Statistics
WavSorter can display information about the size of a file, the date and time it was last 
changed or saved, and its current attributes.
1. Select a file by clicking on it in the File listbox. 
2. Either select File Statistics... from the File Menu, press F2, or right-click on the file. 
WavSorter displays a message box with the file information.

Hint: The "archive" attribute is particularly useful when sorting because it tells you whether 
the file has changed since the last time it was backed up. If you see the archive attribute 
listed for a file, it means the file has changed since it was last backed up.



Working with Folders
Overview
Playing the Contents of a Folder
Copying the Contents of a Folder
Moving the Contents of a Folder
Deleting the Contents of a Folder
Edit Folder Window
Folder Statistics



Folder Overview
The central concept of a folder is that it represents a directory on your disk drive. When you 
copy or move a file to a folder, you are actually copying or moving the file to the directory 
assigned to that folder. More importantly, when you delete a file from a folder, you are 
deleting that file from the assigned directory. 
Similarly, when you copy or move a folder's contents from one folder to another, you are 
copying or moving the files from one directory to another.
Folders come in two colors, and various appearances (click here), and change appearance as 
you interact with them.



Playing the Contents of a Folder
There are two ways to play the sound files in a folder:
· Select the folder you want to play by clicking on it and then click the Play Directory     

button (you are, after all, playing the directory assigned to that folder).
Or
· Drag the folder to the Play Directory button and drop it on the button.

WavSorter Pro Feature! Note: Only WavSorter Pro 
can play MIDI files.

WavSorter will play, in alphabetical order, all the sound files in the folder. You can stop play 
at any time by clicking the Stop   button  . Unlike individual files, you must wait until one 
folder is finished playing before starting play of another one. Note that files will play in the 
background, which means you can continue working on other things--even minimize 
WavSorter--while a folder is playing.
Its OK to try to play a non-sound file (one thats not a Wav or MIDI file). WavSorter checks to
make sure that a file is playable; if its not, WavSorter just skips it. However, if you have a lot 
of files in the directory you play, you may seriously tie up your computer. To prevent this, 
WavSorter stops trying after the fifth bad file.

Hint: Since files play in the background, you can use this feature as you would a "jukebox." You
can use folders to create "albums" of music or sounds!    You could even use WavSorter 
Pro's support of multiple configurations to create collections of "albums."



Copying the Contents of a Folder
If the default drag operation is copy, then drag the folder containing the files you want to 
copy to another folder and drop it on that folder. If the default drag operation is move, then 
hold down the CTRL key while dragging the folder. Note that you are copying the files in the
folder, not the directory itself.

See: Default Drag Operation



Moving the Contents of a Folder
If the default drag operation is move, then drag the folder containing the files you want to 
move to another folder and drop it on that folder. If the default drag operation is copy, then 
hold down the CTRL key while dragging the folder. Note that you are moving the files in the 
folder, not the directory itself.

See: Default Drag Operation



Deleting the Contents of a Folder
There are two ways to delete the contents of a folder:
· Drag the folder containing the files you want deleted to the Delete   button   and drop it on 

the button.
Or
· Select the folder containing the files you want to delete by clicking on it. Then click on 

the Delete button.
When you drop the folder or click the button, you will be asked if you want to proceed. If 
you want to proceed, you will be given a choice of either confirming the deletion of each file 
or deleting all the files in the directory without confirmation. After all the files have been 
deleted, you will be asked if you want to also delete the directory.
WavSorter Pro gives you the ability to assign a custom sound effect to delete operations.

Hint: Since you can confirm the deletion of each file, this is handy way of "weeding" out 
unwanted files. Simply click Yes to delete a file you don't want; click No to keep a file 
you do want.



Displaying Folder Statistics
When you right-click on a folder, WavSorter displays a message box with information about 
the complete path of the directory assigned to that folder, number of files, and size of the 
directory.

Hint:    You can also display folder statistics by choosing Folder Statistics... from the file menu or
by pressing F8.



Shortcuts and Techniques
Shortcuts

Double-Clicking
Right-Clicking
Navigating with Folders
Using Magic Target Help

Techniques
Using a Sort Folder
Multi-stage Sorting
Sorting to a Diskette
Using Multiple Configurations
Creating a Custom Drag Icon
Using the OpLight
Background Sound and Music for AfterDark



Double-Clicking
You can play a file by double-clicking on it in the File listbox. It's not necessary to wait for 
one file to stop playing before double-clicking on another.



Right-Clicking
You can display statistics about the currently selected directory or file by right-clicking on it. 
You can right-click on a folder to display statistics even if it's not the currently selected one.



Navigating with Folders
Since selecting a folder causes the Directory listbox to change to the directory assigned to 
that folder, you can navigate your directory structure using folders. For example, instead of 
working your way up and down through directories, simply click on a folder to jump straight 
to the directory assigned to that folder.



Using Magic Target Help
Magic Target Help provides a way for you to learn about an object, button, or menu item 
simply by clicking on it. When you choose Magic Target Help from the Help Menu, the 
cursor becomes a crosshair. Click on something and a popup box provides you with a short 
description. All menu items and buttons, and most objects, respond to Magic Target Help.
Some descriptions also list related topics; click on the related topic hotspot to jump to a full 
topic containing in-depth information. However, there's a quirk in the way Microsoft put 
together Windows Help: the jump to a full topic from one of these little popup topics only 
works if Windows Help is already on the screen. If it's not displayed, nothing happens when 
you click on the jump. You can make sure that Windows Help is displayed by selecting 
Contents from the Help menu before starting Magic Target Help.
When you're finished with Magic Target Help, click on the box that says "Click here when 
done with MT help" and the cursor returns to what it was before Magic Target Help was 
selected.

Hint: Use Magic Target Help to take a tour of WavSorter. It's a handy way to learn about 
features and how to do things.



Using a Sort Folder
A sort folder allows you to have all your unsorted sound files in one place. This makes 
sorting a lot easier and more efficient.
To create a sort folder:
1. Select a directory you want as the sort directory, or create a new directory and name it 

something appropriate like "unsorted".
2. Assign that directory to a folder and label the folder "Unsorted" or whatever you want to 

call it.
3. Copy or move to that folder all the files you want to sort.
Now, when you want to sort files, just select your sort folder by clicking on it. The files 
contained in that folder will be displayed in the File list box and you can sort by dragging 
them to the appropriate folders.

Hint: When you download sound files, unzip them into your sort directory and they will be 
ready to sort.

See: Edit Folder Window



Multi-Stage Sorting
Note:    You need WavSorter Pro, with its ability to create, save, and use multiple 
configurations in order to use multi-stage sorting effectively.
You can create a group of related folders and save your configuration. When you want to use 
that group, load the configuration which contains it. Multi-stage sorting involves using 
groups of folders to achieve increasingly specific levels of sorting. 
For example, say you have a bunch of animal sounds. You could sort those sounds first into a 
folder labeled "Animals." From there, you could sort them into a group of folders 
representing specific types of animals such as, domestic, farm, and wild. From those folders, 
you could sort the sounds into a group of folders representing specific animals of each type 
such as dogs, cats, and parakeets for domestic animals; pigs, chickens, cows, and goats for 
farm animals; and lions, tigers, and bears for wild animals (Oh my!).

Hint: When you create a group of related folders to use in multi-stage sorting, always include 
in each group a folder representing the next higher level. That way, you can navigate 
straight to the directory you are going to sort from.



Sorting to a Diskette
A folder can represent a directory on a diskette just as easily it can represent a directory on 
your hard disk.
You could, for example, use WavSorter to sort out the clutter of sound files on your hard disk,
by moving sound files to a diskette for archiving. This works particularly well for sound files 
you like, but don't need to have instantly available on your hard disk.



Creating a Custom Icon
Note:    You need WavSorter Pro in order to assign a custom icon.
Although you can assign any of your icons as the drag icon, you may want to customize it 
first. Using a drag icon that is very large or has a solid background will make it difficult to 
see the object underneath it.
To avoid this problem, use an icon editor (such as Icon Works) to redraw the icon in a smaller
size, if necessary, and make the background transparent.



Using the OpLight
The OpLight tells you what WavSorter is doing at any given time. When you drag something 
over an object, the OpLight also tells you what action will occur when you drop whatever 
you're dragging onto that object. The OpLight will display "DONE" if the operation was 
successful.



Background Sound and Music for AfterDark
You can use the jukebox feature of WavSorter to play background sound and music for 
AfterDark screen savers. To do this, create a folder (or "album") of the sounds or music you 
want to play in the background, or use an existing folder or directory. Highlight the folder or 
directory, click on the Play Directory button, minimize WavSorter, and activate your screen 
saver.
Naturally, if you're already using WavSorter's jukebox ability to play sound or music in the 
background, it will continue to play anytime your screen saver activates.
Note:    You need WavSorter Pro in order to play midi files.



Using the Mouse
Selecting Stuff

Selecting Directories
Selecting Files
Selecting Folders

Drag and Drop
Dragging and Dropping
Default Drag Operation

Getting Information with the Right Mouse Button
Displaying File Statistics
Displaying Directory Statistics
Displaying Folder Statistics



Selecting Directories
To select a directory, single-click on it in the Directory listbox. If the directory you select is 
assigned to a folder, that folder will become highlighted; otherwise, no folder will be 
highlighted.



Selecting Files
To select a file, single-click on it in the File listbox. The complete path of the selected file is 
displayed in the filename panel (just below the Directory listbox).



Selecting Folders
Select a folder by single-clicking on it. If the folder has a directory assigned to it, the 
Directory listbox will change to that directory, and the folder will have a yellow rectangle on 
it. Otherwise, the directory list box doesn't change, and the folder will have a green rectangle 
on it.



Dragging and Dropping
There are three objects in WavSorter that you can drag and drop: directories; files; and 
folders. The object you are dragging is called the source. The destination of your drag and 
drop operation is called the target. There are five targets in WavSorter: the Play File   button  ; 
Play Directory   button  ; Launch   button  ; Delete   button  ; and folders.    
To drag, position the mouse pointer over the source object, press and hold down the left 
mouse button, and drag to the target object. To drop the source object, simply release the 
mouse button. When you are over a target, the OpLight will tell you what operation will be 
performed when you drop the source onto the target.



Displaying File Statistics
Select a file by clicking on it in the File listbox. Once you've selected a file, right-click on it 
to display a message box containing information about that file's size, date and time it was 
last changed or saved, and its attributes.



Displaying Directory Statistics
Select a directory by clicking on it in the Directory listbox. Once you've selected a directory, 
right-click on it to display a message box containing information about the size of the 
directory and the number of files it contains.



Displaying Folder Statistics
Right-click on a folder and a message box appears that provides information about the 
complete path of the directory assigned to that folder, number of files, and size of the 
directory.



How to Order
You can order WavSorter Pro for $14.95, plus tax and shipping, from Public (software) 
Library with your VISA, MASTERCARD, DISCOVER, or AMERICAN EXPRESS 
card by calling 800-242-4775 (from overseas: 713-524-6394). These numbers are for 
ordering only. For information about dealer pricing, volume discounts, site licensing, the 
status of    your shipment, the latest version number, or for technical support, contact 
Shepherd Software.
When ordering from Public (software) Library, specify #10868. Orders are shipped via U.S. 
Postal mail within 48 hours of receipt.

If you want to order WavSorter Pro by mail with a check or money order, click here. This 
will take you to the order form.
For questions about your order or technical support, please contact Shepherd Software via 
electronic mail.



WavSorter Pro
WavSorter Pro has all the features of WavSorter, plus:
      WavSorter Pro plays MIDI files. Use WavSorter Pro to sort and organize your midi 

collection. You can even create albums of your favorite songs and use WavSorter 
Pro's jukebox ability to play them in the background!

     WavSorter Pro lets you assign your own sound effects to launching and deleting. 
Choose a .wav file from your own collection and tell WavSorter Pro to play it when 
launching or deleting a file.

     WavSorter Pro lets you assign your own custom icon for drag and drop operations. 
Add a personal touch to your copy of WavSorter Pro!

      WavSorter Pro has an expanded help system, with even more graphics and features. 
WavSorter Pro's help system uses screen captures and graphics to enhance the 
effectiveness of help.

     WavSorter Pro gives you the ability to edit the sounds associated with Windows 
system events. You can do this easily from within WavSorter Pro by using the Assign
System Sounds window. Assign sounds "on the fly" while sorting sound files!

     WavSorter Pro gives you the ability to create and edit Windows file associations. With
WavSorter Pro, there's no need to go through File Manager; simply use WavSorter 
Pro's built in File Association window to create and edit file associations as you 
need them.

     WavSorter Pro lets you create, save, and utilize a virtually unlimited number of 
configurations, greatly expanding the possible uses of WavSorter Pro. Create 
your own configurations, each customized for a specific use!

And WavSorter Pro is only $14.95 through December 31, 1993!!
How to Order



Also From Shepherd Software
    Handyman Wallpaper Hanger

Windows 3.1 has a very awkward procedure for changing Windows wallpaper using Control 
Panel. Not only is there no way to preview a bitmap, the drop down box listing your bitmap files 
only lists bitmaps residing in your Windows directory. This means you either have to clutter your
Windows directory with bitmap files or you have to manually enter the complete path to a 
bitmap you want to display as wallpaper.Yechh...
Handyman Wallpaper Hanger is designed to easily preview bitmaps and change the wallpaper 
displayed on your Windows desktop. You can preview your bitmaps with Handyman and then 
install the one you want by simply clicking on the Change Wallpaper... button. 
Another very useful advantage of using Handyman is that you can store your bitmaps in a 
directory other than your Windows directory. Storing your bitmaps in a different directory 
eliminates some of the size and clutter of your Windows directory and helps in keeping your 
bitmaps more organized. You can store and preview your bitmaps on any valid drive, including 
disk, network, and CD-ROM drives. Handyman will also remove existing wallpaper if you 
decide you don't want to display any.

The evaluation version, HANDYxx.ZIP, is available as shareware from the WINFUN forum 
of CompuServe, or may be available on your local BBS. If you do not have access to either 
CompuServe or a BBS, contact Shepherd Software for assistance in obtaining a copy.
Handyman requires Windows 3.1 and VBRUN300.

    Interior Designer
Tired of looking at the same old font for icon titles? Don't you wish MicroSoft had included an 
easy way to preview and change the icon title font and size in Windows 3.1? I did too...after all, 
what's the use of all those thousands of fonts if you can't have some fun with customizing your 
own screen display?
Interior Designer provides an easy, graphical, way to preview fonts and sizes for icon titles and 
change icon titles to the font and size of your choice. When you preview a font and size, it's 
displayed in a window designed to resemble an actual Program Manager group window so that 
you can see what your display will look like before making any changes to your Windows 
preferences.

After you've decided on a font and size, simply click a button and your choice is put into 
effect. You only need to do this once because Windows remembers your font and size choice 
and will automatically use it each time Windows starts until you change it again.
The evaluation version, IDxx.ZIP, is available as shareware from the WINFUN forum of 
CompuServe, or may be available on your local BBS. If you do not have access to either 
CompuServe or a BBS, contact Shepherd Software for assistance in obtaining a copy.
Handyman requires Windows 3.1 and VBRUN300.



About Windows wallpaper
You can display a bitmap in the background in Windows. This bitmap can be either centered 
(generally used for pictures), or tiled (generally used for designs and patterns).



About Windows desktop
The "desktop" refers to the screen background for Windows. Application windows, dialog 
boxes, and icons all appear on this background.
You can display a bitmap as "wallpaper" on the desktop, or you can choose (through Control 
Panel) a color for the desktop. Application windows, dialog boxes, and icons will then all 
appear displayed on top of this wallpaper or colored background.



Getting Started
What is WavSorter?

Overview
The WavSorter Main Window
The WavSorter Help System
The Philosophy of WavSorter
Acknowledgements

Quick Start
WavSorter Pro



Overview
WavSorter provides an intuitive way to sort sound files. It uses a folder as a metaphor for a 
directory; operations performed on a folder are in reality being performed on the directory 
assigned to it. You can assign directories from any valid drive to a folder.
Once you've assigned directories to the folders, you sort files by dragging them to the 
appropriate folder. Behind the scenes, WavSorter copies or moves the file to the folder's 
directory.
Note that almost everything you see on the screen can respond to dragging and dropping. If 
you're not sure whether an object will perform an operation when something is dropped on it,
drag a directory, file, or folder over it and watch the OpLight for information.



The WavSorter Main Window
You can use this topic as a visual index to the parts of WavSorter.

Menu Bar

File These items let you delete directories; create directories; rename directories; rename files;
delete files; display file statistics; display directory statistics; and exit WavSorter.

Edit With items on the Edit menu, you can edit folder setups, turn off and on message box 
sound effects, select icons, and, with WavSorter Pro, edit Windows system event sounds 
and file associations.

Options Options menu items control how WavSorter works: message box sound effects, 
icons used, whether dragging is by default a copy or move operation, how 
statistics are displayed, and, with WavSorter Pro, manage configuration files. (See
Configuring WavSorter.)

Help The Help menu is the way you learn about WavSorter, through this help system. (See The
WavSorter Help System.)

Caption
The window caption identifies WavSorter, and lists the name of your current configuration 
file. Since only WavSorter Pro has the ability to create, edit, and use multiple configurations, 
the evaluation version always displays "default.ini".

Toolbar
The Toolbar has six buttons that make WavSorter very easy to use. Except for the Exit 
button, you can use these buttons by either clicking on them or dragging an object on to 
them. Click a button name below for more information.

Play File Stop Play Directory

Launch Delete Exit



File Controls
Several controls work together to let you display and select the files on your computer for 
WavSorter to work with.
Drive and Directory listboxes
File Type controls
File listbox
WavSorter displays the name of the currently-selected file in the Filename box.

The File Sorting Area
In the right half of WavSorter's main window you'll find two very important objects; these are
the heart of WavSorter.
The OpLight
Folders



The WavSorter Help System
Too often, most programs' Help consists of nothing more than the printed manual's word 
processor files just dumped into an alleged "help" system, with no attempt at all to exploit the
wonderful possibilities of an online, hypertext system. 
WavSorter's help system has been designed to take full advantage of hypertext's capabilities. 
It's kind of analogous to the way that you can accomplish a given task in WavSorter several 
ways (for example, you can play a sound file by selecting it and clicking the Play button, you
can double-click the filename, or you can drag the filename over to the Play 
button...everything works). You can find out what you need to know in this help system by 
approaching it from many different directions:
· The traditional way: Select Contents from the Help menu. You get a table of contents, 

from which you can select a major category; from the category table of contents, select a 
specific topic. Use the Back button to move back up, or the >> (Next) or << (Previous) 
buttons to move forward and back through related topics.

· You can search a list of keywords by clicking the Search button. This works like an 
index: click on a keyword to display a list of the topics related to that keyword. Use this 
when you think what you're looking for might be related to a word or phrase (such as 
"folders" or "sort").

· Pressing F1 from the main WavSorter window, or when a dialog box or window is 
displayed, takes you to a topic that describes what you're seeing on the screen.
And then there's the jewel in the help system crown: Magic Target Help.    Magic Target 
Help integrates the information you need right into the program's user interface. You turn 
on Magic Target Help on the Help menu, then touch your "magic target" cursor on menu 
items, buttons, and objects you see on the screen; those objects pop up a little window 
that explains what they do. In most cases, each little popup has a hotspot that will take 
you to a deeper treatment of the subject. Note that due to the way Windows handles help, 
WavSorter Help must be running in order to use the hotspots. If you want to use the 
hotspots, simply start WavSorter Help by choosing Contents on the Help Menu before 
starting Magic Target Help.

A note about the help system with the evaluation version of WavSorter:
The evaluation version of WavSorter is distributed as shareware, which means that the 
majority of people who get a copy of the evaluation version of WavSorter will do so by 
downloading it from a service such as CompuServe or their favorite BBS. When you use 
those services, every minute costs you, so the evaluation version includes just a simplified 
version of this help system to keep it smaller, and to keep your costs down.
The main difference between the two help systems is that the WavSorter Pro version uses 
many more graphics--screen captures and diagrams, for example; while the evaluation 
version relies more on words. Graphics provide a much more effective means of 
communicating information but they also significantly increase the size of the help file, 
which would have resulted in higher download costs for most people.



Yep, yet another compelling reason to register and receive WavSorter Pro!
See: Ordering WavSorter Pro



The Philosophy of WavSorter
The idea for WavSorter came about because I had accumulated a lot of .WAV files from 
various BBS's. Unfortunately, Windows doesn't provide any easy way of sorting, let alone 
playing, them. Almost in desperation I thought, "Well, hey, I'll just write a quick little applet 
to sort these buggers." Eight months and many hundreds of hours later (now 14 months and 
over a thousand hours later for version 3.0), "Viola!"--WavSorter is completed...and I'm ready
to start sorting. 
It'll be easier for you.
Actually, the product you see now bears little resemblance to my original design. Early on, I 
decided that I wanted to create a program that was not only fun to use but that also had a 
friendly appeal; an engaging personality. This led me to consider the appearance of the 
program and the ways in which the user interacts with it. Along the way, I came to a 
realization which eventually shaped every facet of WavSorter.
I experienced this realization as an image of a VCR sitting placidly on a shelf with its clock 
flashing "12:00" over and over. It occured to me that software is like that VCR: it can 
perform a variety of incredibly complex functions, but only if the user can tell it what to do. 
Everyone can tell their VCR to play, rewind, record, etc., but other features like setting the 
time or programming it to record at a certain time leave most people frustrated and confused. 
The result is that the clock stays on "12:00" and there's a huge market for add-on gadgets that
do the VCR programming for you.
From that point on, my goal became creating an interface which was as concrete and as 
straightforward as the buttons on a VCR, and avoid the obscure user interface which prevents
you from setting the time on your VCR. The result is an interface which appears quite simple 
but which in fact, behind the scenes, performs a variety of very complex and complicated 
tasks. I also provided the ability to customize the interface as much as possible to your own 
personality and taste in the belief that this would further simplify using WavSorter.
If I've succeeded in my goals with WavSorter's design, I owe a great deal to my brother, Bob, 
for his assistance and experience in this area. Fortunately for me, Bob took an early    interest 
in the program and helped guide me through the shoals of application design. Bob's 
unrelenting and uncompromising stand that a program's features should, by god, be 
straightforward and make sense to the user kept me from straying too far into the esoteric. 
Without Bob's steadying influence, WavSorter's interface might well have overshot simplicity
and ended up in obscurity. Thanks again, Bob.
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Message from Bob:
Jim forgot to mention that I assembled this help file from material he originated...and that 
means that I get the last word! Ha ha ha ha (can you tell we're brothers?).
He also forgot to acknowledge himself. Jim started the WavSorter project with a simple 
premise: sound and multimedia support in Windows has meant that most people with sound 
boards have managed to accumulate dozens, even hundreds, of sound files, from public 
domain sources and sound "clipart" collections (I have a CDROM with several hundred 
clipart sound files, and hundreds more on my hard disk). How do you manage these files? 
WavSorter certainly makes managing sound files easy. But more than that, early on, Jim set 
the goal that WavSorter should be more than just easy: it should support many ways of doing 
things, so that whatever you try, it will probably work. Jim also wanted WavSorter to be 
humorous and fun to use. In fact, he wanted WavSorter to be more than "user-friendly"; he 
wanted it to be likeable and to even have something of a personality.
I've been a computer geek for nigh on fifteen years, and I can tell you: WavSorter is no 
ordinary program. Register this puppy, and give Jim a chance to show his stuff on future 
projects. You will benefit, I guarantee it.



Quick Start
If you really want to get started right now, these topics will provide you the bare minimum 
you need to know for using WavSorter:
WavSorter Overview
The WavSorter Main Window
Using Magic Target Help
Using the OpLight
Folder Overview
Dragging and Dropping
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The Usual Fine Print
WavSorter and related files, including technical bulletins and this help file, are Copyright © 1993 by James Shepherd/Shepherd Software. All rights reserved.

This is the evaluation version of WavSorter. It is distributed as shareware for a 30 day evaluation period. You agree by using this product to either register it within 30 days of receipt, or to
discontinue using it. Continued use without registration is a violation of Shepherd Software's copyright.

Shepherd Software makes no warranty of any kind with regard to this software, technical bulletins, or documentation, including, but not limited to, any implied warranties of 
merchantability and fitness for a particular purpose. Shepherd Software shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, 
performance, or use of this product. The software and the information contained in this documentation is subject to change without notice.



The Usual Fine Print
WavSorter and related files, including technical bulletins and this help file, are Copyright © 
1993 by James Shepherd/Shepherd Software. All rights reserved.
This is the evaluation version of WavSorter. It is distributed as shareware for a 30 day 
evaluation period. You agree by using this product to either register it within 30 days of 
receipt, or to discontinue using it. Continued use without registration is a violation of 
Shepherd Software's copyright.
Shepherd Software makes no warranty of any kind with regard to this software, technical 
bulletins, or documentation, including, but not limited to, any implied warranties of 
merchantability and fitness for a particular purpose. Shepherd Software shall not be liable for
errors or for incidental or consequential damages in connection with the furnishing, 
performance, or use of this product. The software and the information contained in this 
documentation is subject to change without notice.



Technical Support
Click here for answers to commonly asked technical support questions.
You're currently using the evaluation version of WavSorter; it's provided so that you can 
evaluate the program and decide whether to register and receive WavSorter Pro, which has 
even more features and enhancements.
Registered users underwrite the cost of providing technical support with their registration 
fees. However, since users of the evaluation version of WavSorter may also have questions or
need support, the following technical support is available while evaluating WavSorter: 
· Under most circumstances, unregistered users may use technical support only once.
· Please gather all your questions into a single support request; I'll try to handle everything 

at once. Particularly, I want to know about anything that's preventing you from using the 
program, or from having a satisfactory experience of the program. The more specific and 
informative you can be, the better. A brief question like "Help, the program won't run" is 
meaningless and provides no clue as to what is causing the problem and how to correct it.

· I also want to hear about your "if only it did this, I'd register and receive WavSorter Pro" 
reactions. Be assured that I'll take it seriously.

Send your support request, and I'll respond within 24 hours.
By Electronic Mail:

Through CompuServe at 71664,2255
By Internet Email to:

71664.2255@compuserve.com
If you have a X.400 email system (for example, MCI Mail), send your message to:

Country=us
ADMD=CompuServe
PRMD=csmail
DDA Type=id
DDA Value=71664.2255

By U.S. Postal Mail:
Shepherd Software
6984 McKinley St.
Sebastopol, Ca. USA. 95472

See: Ordering WavSorter Pro



TANSTAAFL
There Ain't No Such Thing As A Free Lunch
Coined by Robert Heinlein in his classic work "The Moon is a Harsh Mistress." The Universe
always balances its books--there's a fixed amount of energy and matter around, and what's 
used over there isn't available to be used over here.



WavSorter Pro Feature
This is one of the many additional features and enhancements you'll be able to use once you 
register and receive WavSorter Pro.
Tell me about WavSorter Pro
How to order WavSorter Pro



WavSorter Pro and MIDI Files
You've tried to play a MIDI file with the evaluation version of WavSorter. This is one of the 
many additional features and enhancements you'll be able to use once you register and 
receive WavSorter Pro.
Tell me about WavSorter Pro
How to order WavSorter Pro



Sound Files



About Sound Files
A sound file contains data that Windows can play through a device such as a sound board. 
Windows defines two standard formats for sound files:
Wave files are recorded sounds; they're a (more or less) accurate record of any sort of sound 
(including noise and other garbage), stored in a digital format, very much like that used to 
record compact discs, that your computer can work with. Wave files are (usually) identified 
by the extension ".WAV" in their filenames.
MIDI files are like sheet music: they contain the notes that one or more computer-
synthesized instruments should play to make music. MIDI files are (usually) identified by the
extension ".MID" in their filenames; sometimes the extension is ".MDI". 

WavSorter Pro Feature! Note: Only WavSorter Pro 
can play MIDI files.

You must be using Microsoft Windows 3.1 to take advantage of WavSorter. Windows 3.0 
didn't directly support sound, although many people have added multimedia support through 
CDROM upgrade kits and the like; but 3.0 doesn't support other user interface features used 
by WavSorter, so Shepherd Software cannot guarantee that WavSorter will work under 
Windows 3.0.



System Event Sounds



About System Event Sounds
When you're running Microsoft Windows 3.1 with a sound board, Windows associates a set 
of standard sounds with certain system events. These events are such things as starting or 
exiting Windows, system beeps, and so on; and with the various types of message boxes that 
programs can display. Click here to see some common examples of message boxes and 
message sounds.



System Event Sound Examples
Click on the various boxes below to see examples of the various standard Windows message 
boxes, and the system event sounds associated with each one.

Asterisk Default Stop

Question Exclamation

Note that not all programs ask Windows to play the sound associated with a message box 
type; it's up to the programmer to explicitly include that request.



Folders



About Folders
WaveSorter's folders represent directories. They're active little buggers, constantly changing 
colors and reacting to things you do.
Blue folders are ones you've set up already: they have a valid directory assigned to them, and a 
caption; they're "valid." Gray folders are not yet set up.The various folders, and their meanings:

This is a folder that's been set up, "at rest." That is, you haven't clicked it, nor are you about to drop something 
on it.

This is a valid folder after you've clicked on it; it's the currently-selected folder. The directory and file list boxes
will change to the directory assigned to the folder.

This is a valid folder while you're dragging something over it, but before you've dropped the object. It's open 
and ready to receive.

This is a folder that's not set up, and that's not doing much of anything.

This is a folder that hasn't been set up, after you've clicked on it. This folder is selected (even though it isn't yet 
set up), so that you can assign a directory to it and add a label using Folder on the Edit menu.

This is a folder that isn't set up, when you're dragging a directory name from the directory list box (with the 
Shift key held down). If you drop the directory on this folder, you'll assign the directory to it (and the folder will turn
blue!).
See: Working with Folders



Contacting Shepherd Software
Click here for information about other Shepherd Software products.
You can contact Shepherd Software several ways.

By Electronic Mail:
Through CompuServe at 71664,2255
By Internet Email to:

71664.2255@compuserve.com
If you have a X.400 email system (for example, MCI Mail), send your message to:

Country=us
ADMD=CompuServe
PRMD=csmail
DDA Type=id
DDA Value=71664.2255

By U.S. Postal Mail:
Shepherd Software
6984 McKinley St.
Sebastopol, Ca. USA. 95472



Shepherd Software
Click here for information about other Shepherd Software products.
You can contact Shepherd Software several ways.
By Electronic Mail:
Through CompuServe at 71664,2255
By Internet Email to:

71664.2255@compuserve.com
If you have a X.400 email system (for example, MCI Mail), send your message to:

Country=us
ADMD=CompuServe
PRMD=csmail
DDA Type=id
DDA Value=71664.2255

By U.S. Postal Mail:
Shepherd Software
6984 McKinley St.
Sebastopol, Ca. USA. 95472



Shareware



About Shareware
Shareware is not free, nor is it in the public domain; Shepherd Software retains full 
ownership of the program through its copyright. Rather, shareware is a distribution method 
with some powerful benefits:
· You get to try before you buy.
· Shareware costs less because the price isn't inflated by advertising and distribution costs.

You're using the evaluation version of WavSorter, which is distributed as shareware. It is 
designed to provide you with basic features you need for sorting wave files. When you 
register, you'll receive WavSorter Pro, which has many additional features and enhancements,
including the ability to play and sort midi files.



Drag and Drop



About Drag and Drop
"Drag and drop" is a facility in Windows 3.1 that lets you drag objects from one place on the 
screen to another. Where you drop the object tells a program what you want to do, and what 
you drop tells the program who to do it to.
To drag something:
1. Position the pointer over the object you want to drag.
2. Hold down the left mouse button (and keep it held). The mouse pointer will change 

appearance, indicating that the object supports drag-and-drop (if the pointer remains an 
arrow, you can't drag the object).

3. Move the drag pointer over the object you want to drop on (the destination object that 
performs the action).

4. Release the left mouse button.
See: Dragging and Dropping for more information.



Launch



About "Launch"
The term "launch" is a bit of technojargon that means to start an application.
The evaluation version of WavSorter will only start Windows Sound Recorder.
If you're using WavSorter Pro, launching a file means that WavSorter Pro gives Windows the 
name of a file, and Windows looks up the application that can work with the file. Windows 
then starts the application with the file already loaded and ready to use.

See: Launching a File



Associations



About Associations, Associating a File
Windows keeps a table that links filename extensions (such as .WAV) with applications that 
work with each type of file. For example, if you've associated the filename extension .WAV 
with your favorite sound editing application, clicking on the Launch button in WavSorter Pro 
starts your sound editing application with that .WAV file already loaded and ready to use. 
(For further information, refer to pages 130-132 of your Windows 3.1 User's Guide.)
Some extensions are associated automatically when you install an application. To find out if 
an extension is already associated with an application, try launching the file.
The evaluation version of WavSorter only launches Sound Recorder.
WavSorter Pro puts creating and editing file associations right at your fingertips; there's no 
need to go through File Manager to do it.

See: Associating a File



Launch Button



About the Launch Button
Once you've associated a file extension, dropping a file with that extension, or selecting a file
with that extension and then clicking this button, launches the associated program with that 
file already loaded. Some programs will launch but will not load a file in this manner. This is 
a limitation of those programs, not of WavSorter.
Note: The evaluation version of WavSorter will only launch Sound Recorder.

Hint: Associate your sound files with your favorite sound editor so that, if your editor supports 
it, you can launch your editor with the file already loaded.

See: Launching Files
Associating a File



Delete Button



About the Delete (Toilet) Button
The Delete button deletes individual files, all files in a directory, a directory itself, or the 
contents of a folder. When you click the button, it deletes the currently-selected file, 
directory, or folder; or you can drag one of those objects onto this button to delete it. If 
Confirm Deletes is checked on the Options Menu, WavSorter will ask you for confirmation 
before deleting.

See: Dragging and Dropping 
Toilet Sound Effect



Exit Button



About the Exit Button
Clicking this button ends WavSorter; it's the equivalent of selecting Exit from the File Menu 
or double-clicking on the control box. If you've changed your configuration and haven't 
saved the changes to a configuration file, WavSorter will ask you if you want to save your 
configuration.



Play Directory Button



About the Play Directory Button
When you click this button, WavSorter plays all the sound files in the currently-selected 
directory or folder.
When you drag a directory or folder and drop it on this button, it plays all the sound files in 
that directory or folder.
You can select and play only one directory or folder at a time using the Play Directory button,
although you can use the Play button to queue up multiple individual files to play.

See: About Sound Files
Playing the Files in a Directory



Play File Button



About the Play File Button
Clicking on this button plays the currently selected sound file.
Dragging a filename and dropping it on this button also plays the file.
You can queue up multiple files to be played, by continuing to select files and clicking the 
button, or by dragging and dropping multiple files. WavSorter remembers the files youve 
selected to play, and plays them in order.
Avoid copying, moving, or deleting a file waiting to be played; obviously, WavSorter wont be
able to find a file if its been moved or deleted.

Hint: You can also play a file by double-clicking on it in the file list box.
See: Playing a File

About Sound Files



Stop Button



About the Stop Button
The Stop button tells WavSorter to stop playing the sound file that's currently playing (if no 
sound file is playing, this button is greyed-out and doesn't respond).

See: Playing a File
Playing the Files in a Directory
Playing the Contents of a Folder



The OpLight



About the OpLight
The OpLight is an indicator that tells you what kind of drag and drop or other operation 
you're currently performing. Because you can configure WavSorter to perform either a copy 
or move by default, it's a good idea to get into the habit of watching the OpLight while you 
drag, to help you avoid mistakes. 
When the operation has completed successfully, the legend changes to "DONE."

See: Using the OpLight



File Listbox



About the File Listbox

The File Listbox
(located just 
beneath the File 
Type control) 
displays the files
in the currently-
selected 
directory or 
folder.

See: File Extension Filter



Directory Listbox



About the Directory and Drive Listboxes

The Directory listbox lets you 
select a directory that becomes 
the current directory for 
WavSorter operations. 

Just above the Directory listbox
is the Drive listbox. When you 
click on its down-arrow, it 
gives you a list of the disk 
drives on your computer. When
you select a new drive, the 
Directory listbox will change to
show the directories on the new
drive.

See: Working with Directories
Using the Mouse



File Type Controls



About the File Type Controls
The File Type control lets you select the type of file displayed in the File listbox; that is, it 
controls the "pattern" of filenames displayed.
This is a "combo box" control, which means that you can either select from a list by clicking 
the down-arrow symbol, or you can type your own directly into the box. You must press 
ENTER after selecting or typing your choice in order for the change to take effect.

See: File Extension Filter
About the File Listbox




